question

Torsten M. avatar image
Torsten M. asked ·

Maven plugin versioning question

Hello,

I'm working on a prototype for integrating the dynaTrace maven plugin into our continuous integration build.

After downloading and extracting the various Maven Plugins for Versions 3.5, 4.0 and 4.1 from the dynaTrace website Idiscovered that the packaged Maven plugin always has the version number 3.5 but the included plugin jars differ in size.

Are the plugins backward compatible? Otherwise it would be nice, if the plugin versions would match the product version somehow...

Does dynaTrace provide a Maven repository site for downloading the plugin? The address "http://www.dynatrace.com/mavenintegration"; does not work?!?

Thanks

Torsten

continuous delivery
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Andreas G. avatar image
Andreas G. answered ·

Hi

We removed the online repository as we only had very little demand for it. You can still download the plugin from the community download site: Automation Library (Ant, Maven) for Dynatrace

The version also still says 3.5 as the exposed functions from the dynaTrace Automation Library haven't seen significant change since 3.5

As you are using the plugin I would be interested in
a) do you require the online repository?
b) any feedback on missing functionality?

Thanks

2 comments Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Hi Andreas,

Thanks for explanations. Yes it would be usefull to have maven online repository.

It looks like this plugin has already tasks for all REST interfaces of the dynaTrace Server, so for now I don't see missing functionality. Maybe after using it more long time I'll give you feedback and suggestions.

Thanks,

Andrey

1 Like 1 · ·

Good to know that you can work with the current plugin version. I will see what I can do about the online repository and will keep you posted.
I you have any feedback regarding additonal features just let us know through the forum

Thanks

1 Like 1 · ·
Andrey G. avatar image
Andrey G. answered ·

Hi Andreas,

I'm also using the dynaTrace maven plugin into our continuous integration build.

Your last post here was two months ago but versioning issue still exists ;).  There is no dynatrace maven repository available. So for now everybody should fix versioning problem manually and install it in local or company maven repository.

Are R&D still suports this maven plugin or it's abandoned project? ;)

Thanks,

Andrey

Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Andreas G. avatar image
Andreas G. answered ·

Hi Torsten

The plugin should work despite the different version number. Will take ylur recommendation back to R&D though.
As for the download link: thanks for letting us know - will look into that

Andi

Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.