question

Jiri K. avatar image
Jiri K. asked ·

Exclude Component from URL

Hi,

we are monitoring an application both with DC RUM and a Java agent. They report very different times on one URL component. In DC RUM the Server Time for /cometd/connect is more than 28 seconds

but in Dynatrace we can see it is very short.

The application developers tell us this /cometd/connect is something like a ping to maintain active connection and can be excluded from monitoring. While this exclusion is not a problem in Dynatrace, I could not exclude it in DC RUM because it is not an operation but a component of a URL. I tried to exclude it using a regex like this http[^?]*cometd[^?]* but it still appears.

Is there some way of excluding just one component of a URL, not the whole operation?

Thanks,

Jiri

nam probenam console
cometd-dcrum.png (56.0 KiB)
cometd-dt.png (139.8 KiB)
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

1 Answer

Adam T. avatar image
Adam T. answered ·

Hi

Please look into following configuration option:

https://community.dynatrace.com/community/display/DCRUM123/End-of-Page+Components

Best Regards

Adam Tryba

2 comments Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

HI Adam,

probably my following question is a silly one, but according to the documentation

"Loading this component indicates that the page is complete; no further elements are taken into account when calculating metrics for the page."

What if the considered End-of-Page component is not really the component we want to define as the "last one"?

If so, does it cause the stop of calculations for the metrics of the page, as mentioned in the docs, even if it's not what we meant doing?

Thanks in advance,

Raffaele

0 Likes 0 · ·

Ok, so if this is not the 'last one', then indeed, adding excluded url shoud do the trick.

There is just one thing that you have to have in mind - this 'url' may not be of default content type. So when you define such url, please click on the 'content types' tab (for this specific url), and make sure it is set to 'all content types'

3 Likes 3 · ·