question

Ashok G. avatar image
Ashok G. asked ·

tomcat agent connected but services are unable to see in dynatrace server

Hi guys i added tomcat 7 to my dynatrace server 6.3 installed in windows 2008r2

and tomcat installed in linux 64bit

i can see that in dynatrace server host and tomcat service added but status is not running

but rally tomcat is running well in agent machine

i am attaching log files any suggestions ??

appmonconfigurationagent6.3server
logs.png (29.2 KiB)
logs.png (65.4 KiB)
capture.png (29.3 KiB)
1 comment
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

can you show us the agent mapping (go to your system profile edit it and go to the tomcat agent group on the left menu, and click on the agent mapping) and your license (Settings->server->license)?

0 Likes 0 · ·

1 Answer

David A. avatar image
David A. answered ·

Can you show us the agent overview?

9 comments Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

hii david here is picture of agent overview

0 Likes 0 · ·
capture.png (47.7 KiB)

I was refering to this one:

0 Likes 0 · ·
csc9d.png (13.7 KiB)

hi david in agent overview tomcat is not there {you reffered section }

0 Likes 0 · ·
capture.png (21.0 KiB)

Are the tomcar agent pointing to the same collector that the other agents that are connected?

0 Likes 0 · ·

yes same server and collector also installed in same box you can se logs

0 Likes 0 · ·

Sorry for making questions little by little. The application server is up and running well? (the tomcat I mean), this means that you can navigate to your application without any problem.

Can you tell if the incident "application process unavailable unexpected" has been triggered lastly? :

0 Likes 0 · ·
tn84q.png (56.8 KiB)

YESS DAVID incident happe

nd here is screen shot

0 Likes 0 · ·
capture.png (21.3 KiB)
capture.png (33.1 KiB)

The alert is refering to a problem on the agent mapping, but no on the application process shutdown. The incident we need to see if the one that can be find over "easytrravel"->Events->Incidents.

Just to anticipate, can you share your tomcat log too, to see if something is happening on your tomcat too. (maybe using a megaupload or something like this if your log is huge)

Thanks

0 Likes 0 · ·

hi david i amk getting one error message that = agent did not match a system profile.

but in my systemprofile tier existed

0 Likes 0 · ·