question

Víctor S. avatar image
Víctor S. asked ·

Compatibility of Dynatrace AppMon 6.5 with Weblogic version 8.1, running with Java version 1.4.2 under RHEL version 3

We have an application running on a couple of instances of Weblogic version 8.1, this WebLogic Application Server is installed in RHEL version 3, and runs using Java version 1.4.2; we have Dynatrace AppMon version 6.5 and we need to know if this specific configuration is supported. In the official Dynatrace 6.5 documentation is mentioned that WebLogic version 8.1 is supported, but in the “WebLogic Application Server” section (under “Agent Configuration for Java-based Application Servers”), is only given the configuration details for Weblogic 9 and superior, also we have found that for WebLogic 9 the Application Server must be running using at least Java version 1.5, so we now doubt that Java version 1.4.2 is supported; we have already try to install the Dynatrace Agent (using the standard “agentpath” parameter procedure) in one instance of this WebLogic but the server refuses to load the module (the agent); any directions and commentaries would be appreciated. Thanks.

6.5agentjava
1 comment
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Any advice?, I need some directions regarding this, otherwise we will need to resort to open a Support Ticket, but I would prefer to resolve this here first, thanks in advice.

0 Likes 0 · ·
Gabriel P. avatar image
Gabriel P. answered ·

Hi Victor,

With regards to the JVM configuration string, for version 1.4 you would have to use "-Xrundtagent" instead of "-agentpath". Please see the documentation below:

Java Agent Configuration

And you're right to say this version (1.4.2) is not supported. The currently supported JVMs are:

Supported JVMs

Red Hat 3 is also not supported (from System Requirements)

C RedHat Enterprise Linux AS 2, 3 5.11/6.6/6.7/7.0/7.1/7.2

And for WebLogic, version 8.1 is not a supported Application Server, only the Web Service Stack is supported.

Under "Servlet containers & application servers" and inside "J2EE 6/7 compliant app servers"

  • WebLogic Application Server 10/11g/12
  • It states that only versions 10, 11g and 12 are supported.

Under "Web Service Stacks"(1)

  • Oracle WebLogic 8.1/9/9.1/9.2/10/11g/12
  • (1) Deployed in a supported servlet container or application server

The note states that the Web Service Stack of WebLogic versions 8.1, 9, 9.1, 9.2, 10, 11g and 12 is supported when deployed in a supported servlet container or application server which, as noted above, would be WebLogic AS 10, 11g or 12.

Please let us know if this answers your question by accepting the answer.

Thanks!

1 comment Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Thanks for you help Gabriel

0 Likes 0 · ·
he g. avatar image
he g. answered ·

Hello Gabriel:

Are there any possible to support version of JDK1.4.2.How about the AppMon 6.3?

BR

Guangzhi

2 comments Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

The Release Notes describe the supported versions. And according to the 6.3 release notes, 1.4.2 is supported with limitations.

https://community.dynatrace.com/community/display/PROD/Dynatrace+6.3+Release+Notes

Note: there is currently a bug in the display of these notes. You must be logged into the portal to view the Supported Technologies section. We are working to fix that display issue quickly.

-1 Like -1 · ·

Hi Joseph:

Thanks for your reply.I will take look at your links.

BR

Guangzhi

0 Likes 0 · ·