question

Youssef M. avatar image
Youssef M. asked ·

UEM problem with Nginx

Hello,

I have trouble getting the UEM working on my app. I have a Nginx webserver agent installed and working fine on aws, but nothing is injected in my web page

I thought that the javascript agent was automatically injected by the webserver agent. Is it the case? Is there something that I should do on my application server?

I use Appmon 7.0 on Ubuntu 16.04LTS

I installed the web agent with ansible

Thank you in Advance

@Leszek Sobiecki

appmon7.0javascriptdiagnosticsnodejsNGINXweb services
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Youssef M. avatar image
Youssef M. answered ·

Hello Babar,

Thank you for your response, How can i check if these headers do not get blocked in my environment?

1 comment Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Easiest way I would say is access that page through your browser with a dev tool and see if you get the JavaScript agent added to the page in the network resources

0 Likes 0 · ·
Babar Q. avatar image
Babar Q. answered ·

Hello Youssef,

Did you enable the UEM data for this application?

e.g. System Profiel > User Experience > Capturing slide to the right most.

Make sure that the HTTP headers x-dtPostBody, x-dtHealthCheck, and x-dtAgentId do not get blocked in your environment. The UEM Health Check needs them to work properly.

Review the below link for the UEM health check.

https://www.dynatrace.com/support/doc/appmon/user-...

Regards,

Babar

Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.