question

Filip H. avatar image
Filip H. asked ·

misconfigured business transaction - too many splittings

Hello,

I'm getting an error on a misconfigured business transaction. It's appearing on the built-in "webpage request" business transaction. It has reached the maximum splittings ( 50.000 ).

Is there a way I can avoid this from happening? I can reset/clear current business transaction splittings and remove the "measures". As far as I know there are no measures set.

But I'd rather not have to clear these...

Filter for the business transaction is set to

- no robot request

- no image request

- no static content request ( custom - disable all js, css, png, gif, woff, ... requests

- no Synthetic dynatrace request

Splitting is set to: "aggregate to common URI patterns: 10%

php
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

1 Answer

Andreas G. avatar image
Andreas G. answered ·

Hi Filip

If the Split is set to 10% you should not run into this problem unless you have A LOT of Applications. Can you open your System Profile and click on Applications and check how many applications you have defined? In case you have "auto detect" turned on it could be that dynatrace auto-detected a lot of apps based on bogus/bot attempts sending strange combinations for your host name. Let me know what you see in the apps. could be your real problem here

Andi

4 comments Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Hi Andreas,

We've only defined a few applications. Auto application was turned off a while ago. It is however tracing all the other calls to the "Default Application". Is thre a way to turn that off as well? That's probably causing my problem.

Regards,

Filip

0 Likes 0 · ·

Never mind - I think I found it ( User Experience under the system profile settings ).

The question is... How do I remove the "error" of the splittings now. It keeps mentioning the business transaction has too many splittings...

Regards,

Filip

0 Likes 0 · ·

The best is to "Remove Measures" and then "Reset / Clear Current Splitting". these are two context menu options on your BT

Andi

1 Like 1 · ·

Hi @Andreas G.,

In regards to your last post: when you talk about "Remove measures", I suppose you mean by right clicking the BT and click "Remove measures for transaction". But this would remove all measures.

In my specific case I would like to remove the splitting measure which is causing the numerous splittings. So I removed the filter splitting measure (first erased data for that measure, then removed it from the BT and deleted the measure). Afterwards I performed a "Reset splitting" for those applications which were impacted. Since I was still getting the message "Misconfigured Business transaction detected".

So I was wondering if the only way to clear this message is to remove the measure by right-clicking on the BT, instead of individual measures.

Kind regards,
Geoff

0 Likes 0 · ·