question

Adrian L. avatar image
Adrian L. asked ·

Collector Hostname

Hi,

I have an issue with a Appmon instance where we have a single server using a collector hosted on the same machine. The collector has been created using the machine's backup interface and I cannot see a way of forcing the collector to use the primary address. Any new instances created, or if I delete and recreate this single instance, all get the backup address assigned to them. This is an issue as the backup interface is not allowed network access and the customer wants to use availability (ping) plugins, so without the collector binding to the primary interface that has network access, this will fail.

Looking at the hostname and network configuration of the server, all seems ok, and nslookup/ping from elsewhere on the network returns the correct primary address and hostname, so I can't see where the collector config is picking up the backup name/ip address.

I've checked the collector.config.xml and it is not there, neither is it in the collector.ini.

Has anyone experienced and overcome this in the past?

Thanks,

Adrian.

configuration6.3collector
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Melory Z. avatar image
Melory Z. answered ·

Kayan is right, I would try to configure the Bind Address first and if it doesn't solve the issue I would try to install the collector instance with the backup interface disabled and then enabled it again.

Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Adrian L. avatar image
Adrian L. answered ·

Hi,

Removing the collector instance and disabling the backup interface before adding new collectors did the trick.

Thanks,

Adrian.

Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

ronny m. avatar image
ronny m. answered ·

luego de actualizar a la version 7 de dynatrace

cuando agrego un nuevo host manualmente

en vez de aparecer el nombre del dominio aparece la ip en duro

Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Andreas G. avatar image
Andreas G. answered ·

I agree with Kayan and Melory - that should do the trick. can you confirm?

1 comment Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

@Andreas G.

- Melory's second option working, all you need to do is disable backup interface and restart your collector instance. and later enabled backup interface.

@ Melory & Kayan - You guys rock!

Thank you for sharing your knowledge to this community.

Thanks & Regards,

Krunal Dave

0 Likes 0 · ·
Kayan H. avatar image
Kayan H. answered ·

I'm not sure how it is picking up the backup IP, but have you tried do set the Bind Address (in the collector advanced config) as the primary IP?

Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.