question

Daniel B. avatar image
Daniel B. asked ·

Dynatrace Appmon old JVMs & .Net - support & functioning

Hi,

I saw this table about Dynatrace 7.0 supported Java agent's JVMs:

And I was wondering what happens with old JVM versions (specifically with Oracle JVMs < 6).

Despite not having official support, is it any place to check if some old JVM versions will not work correctly with some Dynatrace Appmon versions? Does this old JVMs are being tested with latest Dynatrace updates and we can check the result in some place?

It could be great if we can know the same about .Net CLRs!

Thanks!
Daniel

appmon6.5agent7.0appmon 7upgrade
jvms.png (29.0 KiB)
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

1 Answer

Joe H. avatar image
Joe H. answered ·

Daniel, As a general rule, when a JVM vendor stops supporting a JVM version, then Dynatrace has no choice and must stop supporting a JVM version. What this means is that we stop testing and creating fixes to address a given JVM release, however this does not mean it won't work, we simply don't know.

So feel free to try using AppMon with the older version and see if it works. Of course, just like you'll hear from Oracle, if there's a problem, "please upgrade".

1 comment Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Thanks Joseph

0 Likes 0 · ·