question

Srimathi S. avatar image
Srimathi S. asked ·

Speed index for UEM useractions is not displaying any data.

Hi,
I am not able to get the data for the speed index measure in my BT. I am using appmon 7.1 version. I have created a measure for a page loading action and I am not able to get the speed index for that measure. Can anyone help me on this?

monitoringuemappmon 7business transaction7.1measures
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Babar Q. avatar image
Babar Q. answered ·

Hello Srimathi,

Did you enable both visually complete and speed index capture for a System Profile by selecting the Visually Complete check box in the System Profile - User Experience settings?

Note: Speed Index and Visually Complete metrics are only available on browsers that support mutationobservers. This includes the following browsers:

  • Microsoft Internet Explorer 11 or later.
  • Microsoft Edge 15 or later.
  • Firefox 57 or later.
  • Google Chrome 61 or later.

Speed index is only available for load actions. Visually complete is available for all load actions, but not for AJAX requests, which don't affect the DOM.

Regards,

Babar

1 comment Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

thank you for the reply @Babar Q.

0 Likes 0 · ·
Srimathi S. avatar image
Srimathi S. answered ·

hi @Babar Q.

yes, I have enabled both visually complete and speed index capture for a System Profile by selecting the Visually Complete check box in the System Profile.
And I am using Chrome Version 64 and I am trying to get speed index for a page load action. but still I am not able to get the speed index value.

3 comments Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Hello Srimathi,

Try one more thing e.g. in the System Profile - User Experience settings - actions group change the performance metric from the user action duration to the speed index.

Regards,

Babar

0 Likes 0 · ·
speed-index.jpg (49.2 KiB)

Hi @Babar Q. Thank you..I will try that but if I change the performance metric from user action duration to speed index will i still be able to get both user action duration and speed index??

0 Likes 0 · ·

I mean will it affect the user action duration if I change it into speed index?

0 Likes 0 · ·
Uzair H. avatar image
Uzair H. answered ·

Hi Srimathi,

Did the above solution from Babar resolved your issue? I'm into the same situation and want to try this but your feedback may help.

Thanks,

Uzair

Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Srimathi S. avatar image
Srimathi S. answered ·

Hi @Uzair H. I have not yet tried that as I have another doubt as...if I change that to speed index then I am not sure whether it will affect the user action duration....so waiting for his reply

Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.