question

Nitin D. avatar image
Nitin D. asked ·

Unable to get User Action Details in Purelytics

Hi All,

I am trying to streaming the UEM data to 3rd party tool 'Kibana'. All Visit data is getting exported to Kibana but the User Action details are not getting exported. I can see the User Action count as '19' in JSON message.

I have follow below page for configuration

https://www.dynatrace.com/support/doc/appmon/integ...

PFA screen-shots of configuration and JSON message. Is my configuration is correct ?

Kindly help me to streamline the User Action Details to third party tool.

useraction.png json.txt

configurationuemuser session monitoring7.1unique users
useraction.png (176.9 KiB)
json.txt (2.8 KiB)
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

1 Answer

Babar Q. avatar image
Babar Q. answered ·

Hello @Nitin D.

I was informed that the Elasticserach is not supported with the version 7.0 e.g. Elasticsearch stream is not working with 6.x ES and 7.0 AppMon. Migration to 7.1 will solve the issue.

Which AppMon version do you have because in your tag is mentioned 7.0?

How did you configure the Elasticsearch?

Regards,

Babar

5 comments Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

I am using ApPMon is 7.1.

Sorry for worng tagging.. I have corrected it.

0 Likes 0 · ·

Hello @Nitin D.

In the PureLytics stream configuration you have admin username and the where you are pushing the manual stream the username is elastic.

Please explain me about these users?

Regards,

Babar

0 Likes 0 · ·

Hi @Babar Q.,

Both user names are same. while capturing the screen-shot we have changed it as admin for security purpose.

Thanks,

Nitin

0 Likes 0 · ·

Hello @Nitin D.

Thank you for the clarification.

The user elastic is the default user of the Elasticsearch and you used the x-pack to configure the password.

Am I right?

Regards,

Babar

0 Likes 0 · ·

Yes, that's Correct.

0 Likes 0 · ·