question

Matt J. avatar image
Matt J. asked ·

Dynatrace Test Result Trend in Jenkins is blank despite over a dozen runs

pic1.png

We are doing a PoC of Jenkins / Dynatrace / Browser/UI-Driven Tests integration. We have the pipeline successfully connecting and getting a test run id, we are using a simple Selenium WebDriver script that navigates to a couple of pages on a sandbox app that has both DT .net and DT IIS agents installed. UEM is setup, we pass all the JavaScript variables from the UEM MetaData page etc.

Everything looks good except the Dynatrace Test Result Trend graph in Jenkins is always blank. It looks like it tries to call the rest interface 4 times then finishes. The report summary never updates. Not quite sure why this isn't working and what to do to fix it. The ID jenkins is using is an admin on the DT - 7.1 TCE box and we see data in the Test Automation / Test results dashlet,

Here is the end of the console output.


               
Dynatrace AppMon Plugin - build tear down...
Finishing test run with ID=d18b6530-97cd-46c5-bfbf-442c9462e04f
Connecting to Dynatrace Server REST interface... (ID=d18b6530-97cd-46c5-bfbf-442c9462e04f)
Connecting to Dynatrace Server REST interface... (ID=d18b6530-97cd-46c5-bfbf-442c9462e04f)
Connecting to Dynatrace Server REST interface... (ID=d18b6530-97cd-46c5-bfbf-442c9462e04f)
Connecting to Dynatrace Server REST interface... (ID=d18b6530-97cd-46c5-bfbf-442c9462e04f)
Report summary: {Failed=0, Degraded=0, Volatile=0, Improved=0, Passed=0}.
Finished: SUCCESS
appmonpluginsappmon 7rest api7.1continuous deliverytest automation
pic1.png (36.1 KiB)
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Matt J. avatar image
Matt J. answered ·

OK I figured it out, I needed to add a delay og 60 seconds to the Dynatrace AppMon setup in Jenkins. Works fine now.

1 comment Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Glad you figured it out! it takes some time for AppMon to process the UEM data, so an additional delay is required on the set-up in Jenkins before polling the data.

1 Like 1 · ·
Heather M. avatar image
Heather M. answered ·

Matt and I have now moved this PoC to a live development environment, and we're having the exact same problem as Matt has described above, including the ability to see the data in the Dynatrace Test Results dashlet. We changed the delay to 120 seconds, and this still didn't work. By using the REST API we were able to determine that there is not any data available to poll for 32 minutes. Eventually we are able to poll the data using the REST API, but this doesn't help the Jenkins Test Result Trend graph. Any ideas?

1 comment Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

I would check the status and sizing of the AppMon server - how good is it performing? also did you check if the performance warehouse was correctly connected?

If this small hint doesn't help, you could open a support ticket (don't forget to add the support archive) for our team to look at it.

0 Likes 0 · ·
Heather M. avatar image
Heather M. answered ·

Thanks, Sonja! I opened a support ticket last Wednesday, but haven't heard anything. We'll take a look at the AppMon server and the performance warehouse, thanks so much for the hint!

Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.