question

Sangeetha M. avatar image
Sangeetha M. asked ·

Hi Team,I am not able to see the failure rate of the service

I have created a Business transaction on one service to get the failure rate ,Response Time and Throughput.

Taken text and tile measures tile to display the results
I am getting results like below:

Response Time Failure rate Status(Traffic Light)
0.567s - Green/orange/red

Here my doubt is currently the URL is running but why we are not able to see any failure if there is no failure rate means we should get at last 0% but why it is displaying "-"

Could anyone help on this

@Sangeetha

7.0web dashboarderrors
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

1 Answer

Mathieu C. avatar image
Mathieu C. answered ·

Hello,

"-" means that it haven't transactions linked to your Business Transaction so no failed % calculated.

But, you should have "-" for response time too.

Sorry, it sounds like a silly question but have you checked Failure Rates in BT configuration ?

Regards,

Mathieu

7 comments Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Hello, Thanks for responding!!!

Sorry, it sounds like a silly question but have you checked Failure Rates in BT configuration ?-----yes I did this

But, you should have "-" for response time too.----Really even I getting the same doubt .because I am getting response time but not getting the Failure rate.

How to trouble shoot this thing ?

0 Likes 0 · ·

In Dynatrace Think Client, what do you have when you open the Business Transactions Dashboard of your BT ?

Thanks.

0 Likes 0 · ·

Hi Mathieu,

Thanks for the response.

What we have observed, we could see data on measure. However, when we created BT on the same measure, we could see no data.

We are not able to see Purepath response time,Failed transaction percentage and failed transaction count

But we could see data on normal measure.

Please help on this issue.

0 Likes 0 · ·

Is your measure based on a "Business Transaction Evaluation/Filter/Splitting Value" metric type and configured on Filter section on your BT?

0 Likes 0 · ·

Hi Mathieu,

Thanks for the response

I have taken Response time as metric and Added that measure in filter category of business transaction

0 Likes 0 · ·

Create a metric "Web Requests - URI Patern Value" and add it in filter category of your BT.

Regards,

Mathieu

0 Likes 0 · ·

Thanks Mathieu,

I will try this

0 Likes 0 · ·