question

Xoán T. avatar image
Xoán T. asked ·

Web Request - Header Value measure for splitting not working on Accept-Language header

I am trying to create a Business Transaction where I split all my web requests by the Accept-Language header.

For that purpose, I created a new measure based on Web Request - Header Value, where the only thing I do is checking for this header (no specific values, no regex, nothing, just split by header):

And with this measure I created my own Business Transaction:

(You can see the measure being used in Split Results).

Now, after a few minutes of simulated requests, I go check the results:

As you can see, the amount of measured requests by the Accept Language BT is 0.

I created similar BT and the corresponding split measures, with the HTTP Header User-Agent and Referer (both of them using Web Request - Header Value as template), and as you can see those two work as intended, getting the requests and splitting them by the assigned header content. So the only header I know that has this problem is Accept-Language.

Do you have any idea why this is happening?

Thanks in advance.

appmonappmon 7business transaction7.2webserver
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

James K. avatar image
James K. answered ·

Did you explicitly tell the relevant sensors (Web server or Java servlets) to capture that header? The other two are probably captured by default which is why they would work right away.

In the sensors configuration add that header and make sure you are seeing it in PurePaths.


answers.png (22.5 KiB)
1 comment Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

This was exactly it! Figures the two headers I configure as examples are the ones that are active by default. Such is my luck. Thanks!

0 Likes 0 · ·
Radosław J. avatar image
Radosław J. answered ·

Hi,

First, please check if your measure is working.

You can verify this by searching for it in the Measure Dashoard.

Please give me a feedback.

Radek

5 comments Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

I'm not sure if I got the right dashboard. There wasn't one named literally 'Measure Dashboard', but I found this one called 'Measure Health'.

Problem is, this one I could only get it to show the Business Transaction data:

(The row that starts with 'Name->Accept Language BT' (not the 'Accept-Language' one - That one must be a previous attempt I did)

Is this the info you asked for?

0 Likes 0 · ·

Yes, I'm asking in this topic. When BT doesn't work, you need to verify that the measures selected for it work correctly.

You will find your measure if it worked correctly in selected time frame on Measure Dashboard

/I don't see your attachment/

0 Likes 0 · ·

Can you see it now (down this line)?

0 Likes 0 · ·
measurehealth.png (100.7 KiB)

Ok I see. Could you share Measure Dashboard (please use your measure name to filter on this dashboard)

/In the meantime, you can try to use the same measure in the Filter field when setting the threshold to 1 for filter. Also leave a measure in the split field/

2 Likes 2 · ·

I'm sorry, but I just can't for the life of me find this Measure Dashboard you're talking about. Could you explain to me where I am supposed to find it?

PS: Using the measure as filter still doesn't yield any results. The count is still 0.

0 Likes 0 · ·