question

HIMANSHU m. avatar image
HIMANSHU m. asked ·

Windows Service status monitor plugin : "Plugin Unauthorized " error

Hi Team,

I am getting plugin unauthorized error on windows service status monitor plugin.

(https://community.dynatrace.com/community/display/DL/Windows+Service+Status+Monitor+Plugin)

Details about my setup:

1) I am trying to monitor a service on the collector machine itself

2) Collector service is running via "Local System" account which has admin priveleges

3)Appmon server & collector version : 7.0.35.1009

4) Same collector machine is successfully able to pull all metrics from SQL Server monitoring plugin

(https://community.dynatrace.com/community/display/DL/SQL+Server+Monitoring+Plugin)

(with MS SQL running on same collector machine itself): Mentioning this because SQL server plugin also needs collector service to run from an account having admin privileges

5) Collector OS : windows server 2016

Below are the complete error details:

Schedule Details Name:*********

Status:finished

Description: Type:Windows Service Status Monitor

Last Run:10:47:37 (IST)

Last Run Result:failed

Next Run:-

Current Run:- Duration (last run):< 1s

Schedule:- Business Hours:-

Execution Target:*******************

Plugin Active:active

Result Status:failed

Result:Last polling execution failed

Reason for failure:Error during execution of plugin occurred

Error message:Plugin unauthorized

Detailed error message:Error occurred

PLease suggest possible options that i can try further to troubleshoot this.

THanks

HImanshu Mor

7.0pluginsappmonsaas
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

1 Answer

Radu S. avatar image
Radu S. answered ·

Hi Himanshu,

Firstly, keep in mind this is an extremely old plugin, tested for dynaTrace 3.5.2, so things may naturally break with newer versions of AppMon.

Secondly, you should be able to find a log file associated with this plugin on the collector machine and that may give you some additional details regarding the actual issue the plugin is having (this should be easiest to access from the AppMon client, going in System Information).

Thirdly, at first glance this seems an issue with the account under which the Collector service is running (which is the same account that the plugin will use) and the permission to do whatever the plugin needs to do. An initial test would be to run the SC command which the plugin would be running while being logged in as the Local System user (that the collector is running as). If the command succeeds but the plugin still doesn't run due to being unauthorized, I would suggest creating a new account with admin permissions and running the collector service under this new account.

I hope this helps.

Best regards,

Radu

1 comment Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Hello @Radu S. ,

Thanks for the detailed steps !

i am not able to find any logs because the logfile for this plugin has been blank till now.

i have tried a separate account for running collector service(with admin privileges) but that also did not work. with this separate account , i am able to run sc query command successfully.

at the moment it appears that plugin is not working well with appmon 7.x.

please let me know if you can point out any other issue that i may need to look into.

Thanks

Himanshu Mor

0 Likes 0 · ·