question

ShashiKrishna D. avatar image
ShashiKrishna D. asked ·

How to synchronize time between probes and DCRUM

Hi,

There is a Time synchronization with probes warning in our setup, please help us how to overcome this, what settings have to be changed, please suggest with reference link.

Regards..

Shashi

nam serveresm
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Avin B. avatar image
Avin B. answered ·

Are you perhaps not referring to the time differences in the attached.


1.png (14.3 KiB)
2.png (3.6 KiB)
Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Ulf T. avatar image
Ulf T. answered ·

So do you have your own build of RH?

First check with "YUM LIST INSTALLED NTP" - if it's not there, then go ahead and add it.

Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Ulf T. avatar image
Ulf T. answered ·

Hi Shashi

To start with , the AMD ALWAYS has the NTP.CONF file in the ETC directory. If you don't have that, something is wrong as this is a default component of every *NIX installation.

In Windows, you usually have to either get some third party or Open Source tool as I "Think" the default time mechanism in Windows isn't based on NTP (at least it wasn't before).

But if you go and ask the Network team in your Company, I bet they already have a Time Server somewhere. Use that one for all your machinery. If all your machine synch against that, you will not have any problems, even if their time might not be perfect, but it'll be the same :-)

1 comment Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

I have double check the NTP.CONF file but no luck, please refer the attached SS.

ntp-file-search.png

0 Likes 0 · ·
ntp-file-search.png (22.9 KiB)
ShashiKrishna D. avatar image
ShashiKrishna D. answered ·

Thanks @ulf t. & @Raffaele T.for the information.

Before that i just want to let you know is in fact the probes which are not synchronized are not AMD one's instead Synthetic one and other probe one.

And also I tried to access the file /etc/ntp.conf but I didnot find neither in CAS nor AMD config folder, i am not sure where this files resides.?

Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Ulf T. avatar image
Ulf T. answered ·

Hi

They "should" synch when they talk to the CAS. If this is not happening, then I suggest you open a ticket.

If it is so that a brand new AMD has come online, the adjustment takes place in small steps for every time the CAS and AMD talk.

As the link Raff is pointing to, it eludes to this "If the AMD is not managed by a report server," but I guess yours is?

1 comment Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Yep, if the AMD is not managed by a report server, Shashi please check the AMD General options config:

https://community.dynatrace.com/community/display/DCRUM124/Global+-+General

Check the IP address of the server authorized to set AMD time is the IP address of the main reporting server (usually the primary CAS).

Hope that helps.

Ciao, Raff

0 Likes 0 · ·
Raffaele T. avatar image
Raffaele T. answered ·

Hi Shashi,

the best way to synch the probes is to use an NTP Server, as described here:

https://community.dynatrace.com/community/display/...

Ciao,

Raff

Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.