question

Soorya M. avatar image
Soorya M. asked ·

Enterprise Synthethic Upgradation 12.3.4 to 12.4.12

Hi,

We are planned to upgrade ES from 12.3.4 to 12.4.12 , we need few clarifications before proceeding up-gradation.

1) CSS,CAS,RUM Console, Agent Manager .ES agent - In which order we have to start up-gradation of these components.

2)Up-gradation is adding Service Pack or we have to install 12.4.12 and uninstall 12.3.4, any steps we have to flow.

3)20 ES agents are connected to ES manager, if we upgrade ES manager to 12.4.12 at that time if ES agents in 12.3.4 whether it will be compatible(i.e) agents connect to agent manager and report data to CAS?

4)what are the steps we followed to do "ES agent" up-gradation.If the agent up-gradation affects the scripts which is configured already.

5)While up-gradation, we aware that db credentials it ask, in addition to that any other details we have to be aware of before starting up-gradation.

6)How long downtime requires to do this complete up-gradation. Nearly last 2 years we are using ES, that much data resides in DB.Suggest the approximate time it requires

Thanks in Advance!!

BR

Soorya Mohan

esmcss
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Jaroslaw O. avatar image
Jaroslaw O. answered ·

Hi!

Agent Manager is the data source for the CAS, so the Enterprise Synthetic components need to be updated after core DC RUM - the 12.3 CAS, CSS and RUM Console won't understand the 12.4 Agent Manager. With that in mind:

1. Upgrade DC RUM core first. For sequence and details see Upgrading+DC+RUM. If you don't use AMD as your data source, ignore it.

2. Upgrade Enterprise Synthetic, that is Agent Manager, Agents and Scripting Framework. For details and sequence, have a look at: Release 12.4 Upgrade Checklist

You don't need to uninstall anything. We support a direct upgrade from 12.3 to 12.4. It is recommended to apply the latest service packs before you start the upgrade, but technically, the upgrade should work fine straight from 12.3.4.

The articles linked above help you collect all the information and resources you need to perform the upgrade.

Unfortunately, I can't help you with the expected downtime. The most critical component is the CAS database upgrade - the time to upgrade depends on many factors, not just the size of data.

1 comment Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Thanks @Jaroslaw O. The link which you provided is very helpful!!

0 Likes 0 · ·
Carlos R. avatar image
Carlos R. answered ·

Hello,

About my experience in my customer, recently we upgrade the ESM and DCRUM, this tools have differences versions.

For ESM, we upgrade from the last Services Pack (SP6 to the last versión). from ESM 12.3.6. to 12.4.0 and then Upgrade Services Pack 5 for version 12.4.5 (this is the last version for ESM tool)

For DCRUM we upgrade from 12.3.9 (ServicesPack 9 is the last SP) and then we upgrade to the las versión with the last services pack directly, versión DCRUM 12.4.12.

Abotu the sequence consult the documentations. But i do this job in the follow order:

1) CSS upgrade from 12.3.7 to CSS 12.4.12

2) DCRUM Console 12.3.9 to DCRUM 12.4.12

3) CAS 12.3.9 to CAS 12.4.12 (with out AMD)

4) OsUpdate 12.4.5 for ESM

5) ESM AgentManager

6) ESM Agents.(recorder migrate automatic the script but we recommend, do one backup script, export)

that is all, you not need uninstall anything, the script are compatibles with old versions. (remember testpartner now called Recorder) is the same framework.

Regards.

Carlos Carrasco.
From Santiago, Chile, LATAM

2 comments Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Thanks for sharing your experience @carols C. This is really helpful for us!!

0 Likes 0 · ·

A little clarification.,

>>> the same framework

The Framework needs to be updated with every release or service pack.

0 Likes 0 · ·