question

Shawn G. avatar image
Shawn G. asked ·

Azure Pack site extension throwing error during installation

We are using an on-premise version of Azure pack and we are also using a on premise version of Dynatrace SaaS. we have one agent extension version 1.11.96 available to install. I have configured the following items for installation: Per the instructions provided

DT_TENANT

DT_API_TOKEN

DT_API_URL

DT_SSL_MODE

I saved these configurations

I then logged into kudu to install the site extension. After my restart I am getting the following error in the Dynatrace log.

C:\home\SiteExtensions\Dynatrace>cat log.txt

1/19/2017 4:52:43 PM INFO installing dynatrace agent

1/19/2017 4:52:44 PM ERROR Zip Tool requirement not found.

1/19/2017 4:52:44 PM ABORT Installation failed. See log.txt for more information.

Wondering if anyone has run into this issue and if there is anything I can do to resolve? I know there can be some differences when using on-prem vs. SaaS so wasn't sure if I am running into this issue or if there is something else I need to do.

Let me know.

Regards,

Shawn Givan

configurationoneagentinstallationazure
kudo.png (39.8 KiB)
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

1 Answer

Martin G. avatar image
Martin G. answered ·

Hi,

Sorry for the inconvenience. The Site extension is currently only tested and supported for Azure public cloud.

The problem here seems to be that Azure Pack does not provide the necessary Zip Tools. Azure public cloud offers 7zip, for example.

Azure Pack is not under active development by Microsoft anymore, so we will focus on Azure Stack instead, once it is generally available.

1 comment Share
10 |2000000 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 50.0 MiB each and 250.0 MiB total.

Martin,

That is unfortunate, but not surprising for the same reasons you mentioned above. I am bringing this question back to folks who know more about Azure pack then I do, but wasn't sure if this was something anyone had run into and solved. If I find out anything I will update this question. Thank you for the info.

Regards,

Shawn Givan

0 Likes 0 · ·